Forum Update October, 2017

Introduce yourself, discover who else is here, and get news and information about the forum. Most of all, tell us what Chile means for you.

Moderator: eeuunikkeiexpat

User avatar
admin
Site Admin
Posts: 22289
Joined: Sat Aug 26, 2006 11:02 pm
Location: Frutillar, Chile
Contact:

Re: Forum Update October, 2017

Post by admin » Tue Oct 17, 2017 8:14 am

Another question for users.

Are people running in to slow loading pages from the forum?

I am finding the page loads tend to hang on diffrent devices like it is waiting for something to render in the background. It does not do it all the time, so im trying to trouble shoot it. I might have a dirty catch from the old site.
Spencer Global Chile: Legal, relocation, and Investment assistance in Chile.
For more information visit: https://www.spencerglobal.com

From USA and outside Chile dial 1-917-727-5985 (U.S.), in Chile dial 65 2 42 1024 or by cell 747 97974.

User avatar
RuneTheChookcha
Rank: Chile Forum Citizen
Posts: 2130
Joined: Thu Aug 07, 2008 3:02 pm
Location: Valparaíso (...a "World Heritage Site")

Re: Forum Update October, 2017

Post by RuneTheChookcha » Tue Oct 17, 2017 1:07 pm

admin wrote:
Tue Oct 17, 2017 8:14 am
Another question for users.

Are people running in to slow loading pages from the forum?

I am finding the page loads tend to hang on diffrent devices like it is waiting for something to render in the background. It does not do it all the time, so im trying to trouble shoot it. I might have a dirty catch from the old site.
Before the update, the pages almost always wanted to hang on, for about 30 to 45 seconds if memory serves, on MySQL database "INSERT" queries, means, when posting a new message. But after that, when doing "UPDATE" (means, when editing the existing post) all was done instantly.

Now, I will measure how this post is inserted into the DB.

Hitting "Submit"...
perdimonocle-19

User avatar
RuneTheChookcha
Rank: Chile Forum Citizen
Posts: 2130
Joined: Thu Aug 07, 2008 3:02 pm
Location: Valparaíso (...a "World Heritage Site")

Re: Forum Update October, 2017

Post by RuneTheChookcha » Tue Oct 17, 2017 1:11 pm

Guess what? 25 seconds waiting, and the following error is coming up:

No route found for "GET /posting.php" (from "posting.php?mode=quote&f=2&p=178728")

Yet, the post is posted.
perdimonocle-19

User avatar
RuneTheChookcha
Rank: Chile Forum Citizen
Posts: 2130
Joined: Thu Aug 07, 2008 3:02 pm
Location: Valparaíso (...a "World Heritage Site")

Re: Forum Update October, 2017

Post by RuneTheChookcha » Tue Oct 17, 2017 1:14 pm

But the above post is posted with no errors whatsoever, in 5 seconds waiting time. Regarding the original post, I tried to repost it after the error, as I thought it was not posted, and I found out it was posted twice. So deleted the duplicate. About 10 seconds waiting while deleting.

So, looks as the database INSERT/DELETE queries tend to delay a bit. But note I am on a mobile 3G link. Let someone on a WIFI connection post and measure the time.
perdimonocle-19

User avatar
RuneTheChookcha
Rank: Chile Forum Citizen
Posts: 2130
Joined: Thu Aug 07, 2008 3:02 pm
Location: Valparaíso (...a "World Heritage Site")

Re: Forum Update October, 2017

Post by RuneTheChookcha » Tue Oct 17, 2017 1:15 pm

I am lost now. The very last post posted with no delay. Or about 1 second delay. OK, enough experimenting.
perdimonocle-19

User avatar
tiagoabner
Rank: Chile Forum Citizen
Posts: 1162
Joined: Sat Mar 04, 2017 9:48 am
Location: Concón

Re: Forum Update October, 2017

Post by tiagoabner » Tue Oct 17, 2017 2:41 pm

I just got the same "GET" error message when trying to access this link: app.php?t=14174
I'm NOT your lawyer, accountant or financial planner. All information at this post should be considered for your entertainment only. Consult a professional before making a decision regarding whatever topic was mentioned in this post.

User avatar
admin
Site Admin
Posts: 22289
Joined: Sat Aug 26, 2006 11:02 pm
Location: Frutillar, Chile
Contact:

Re: Forum Update October, 2017

Post by admin » Tue Oct 17, 2017 2:55 pm

think I managed to ban the cookie monster. We have our own

8_0

Silly useless piece of EU bureaucracy.

Yea, there is a redirect error with the .htaccess file not playing well with the native redirect. Still running that one down.

They did some strange stuff with this release. Perhaps if i beat another millennial, it will beat the bugs out of the system. :'-(
Spencer Global Chile: Legal, relocation, and Investment assistance in Chile.
For more information visit: https://www.spencerglobal.com

From USA and outside Chile dial 1-917-727-5985 (U.S.), in Chile dial 65 2 42 1024 or by cell 747 97974.

User avatar
RuneTheChookcha
Rank: Chile Forum Citizen
Posts: 2130
Joined: Thu Aug 07, 2008 3:02 pm
Location: Valparaíso (...a "World Heritage Site")

Re: Forum Update October, 2017

Post by RuneTheChookcha » Tue Oct 17, 2017 9:02 pm

No way to kind of "clean install" these thingies (phpBB/server), and then to import the existing posts database into the new clean install?
perdimonocle-19

User avatar
admin
Site Admin
Posts: 22289
Joined: Sat Aug 26, 2006 11:02 pm
Location: Frutillar, Chile
Contact:

Re: Forum Update October, 2017

Post by admin » Tue Oct 17, 2017 9:19 pm

Not on a 10 year old database.

Dont think it is a database issue, although i probably need to run some maintence on it.

There is a cache issue going on. I probobaly got some old stuff that needs cleaning.

There are some bugs being reported for this version of phpbb, and i am expecting a new release.

Overall got some optimization and tuning to do also.

We also went to php7.1, and did an apache upgrade and i never tweaked the settings for our server. I had the old configs pretty well optimized.
Spencer Global Chile: Legal, relocation, and Investment assistance in Chile.
For more information visit: https://www.spencerglobal.com

From USA and outside Chile dial 1-917-727-5985 (U.S.), in Chile dial 65 2 42 1024 or by cell 747 97974.

User avatar
Ignite
Rank: Chile Forum Citizen
Posts: 166
Joined: Thu May 01, 2008 1:23 am

Re: Forum Update October, 2017

Post by Ignite » Wed Oct 18, 2017 3:51 pm

Thanks Admin. Looks good!

User avatar
admin
Site Admin
Posts: 22289
Joined: Sat Aug 26, 2006 11:02 pm
Location: Frutillar, Chile
Contact:

Re: Forum Update October, 2017

Post by admin » Wed Oct 18, 2017 4:06 pm

o.k., think I got some of the bug list trimmed down. Hopefully the broken redirects are fixed. Let me know if you find any more around.

Sure there are still some more to yet be discovered.
Spencer Global Chile: Legal, relocation, and Investment assistance in Chile.
For more information visit: https://www.spencerglobal.com

From USA and outside Chile dial 1-917-727-5985 (U.S.), in Chile dial 65 2 42 1024 or by cell 747 97974.

User avatar
admin
Site Admin
Posts: 22289
Joined: Sat Aug 26, 2006 11:02 pm
Location: Frutillar, Chile
Contact:

Re: Forum Update October, 2017

Post by admin » Thu Oct 19, 2017 8:27 am

Still running in to the submit error. Will go do some more bug hunting.
Spencer Global Chile: Legal, relocation, and Investment assistance in Chile.
For more information visit: https://www.spencerglobal.com

From USA and outside Chile dial 1-917-727-5985 (U.S.), in Chile dial 65 2 42 1024 or by cell 747 97974.

Post Reply